Мир объектов Excel 2000

Скатерть с тефлоновым покрытием на www.olivatextil.ru. | мебельные рольставни купить |

9


  Лекции

Основы офисного программирования и документы Excel

1.  

Начала программирования в Excel

2.  

Excel для математиков

3.  

Объекты Excel

4.  

Excel и базы данных

5.  

Объекты ADO

6.  

Объекты ADO (продолжение)

7.  

Создание интерактивных офисных д...

8.  

Анализ деятельности офиса

9.  

Финансист - оптимизатор. Проект ...

10.  

Возможности и применение Office ...

11.  

Создание интерактивных Web-докум...

12.  

Проекты моих студентов

    Экзамен
    Сдать экзамен экстерном

Основы офисного программирования и документы Excel

версия для локальной работы

2. Лекция: Excel для математиков

Страницы:

« |

1

|

2

|

3

|

4

|

5

|

6

|

7

|

8

|

9

|

10

|

11

|

12

|

вопросы | »

|

для печати и PDA

  Если Вы заметили ошибку - сообщите нам.  

Включить комментарии

|| Настройки

|| Модерация

|| Помощь

Нужно понимать, что когда используется Решатель, многое зависит еще и от того, как сформулирована задача. Решатель допускает различные постановки одной и той же задачи, а также имеет ряд параметров, позволяющих управлять процессом решения. Так, при решении системы линейных уравнений можно, например, рассматривать задачу как задачу минимизации следующей функции:

Ф(X) = F12 (X) + F22 (X) + … +Fn2 (X) -> Min

При минимизации этой функции можно и не задавать ограничения. Понятно, что решение системы исходных уравнений является точкой минимума целевой функции Ф(X). На следующих рисунках показана постановка задачи и ее решение для этого варианта постановки:

Второй вариант постановки задачи

увеличить изображение
Рис. 2.16.  Второй вариант постановки задачи

Решение, найденное Решателем, во втором варианте

увеличить изображение
Рис. 2.17.  Решение, найденное Решателем, во втором варианте

Как видите, в обеих постановках Решатель успешно находит решение системы линейных уравнений. Чтобы убедиться, что "проклятие размерности" не так уж и страшно Решателю, я провел еще один эксперимент, выбрав задачу большей размерности, и стал искать решение системы из пяти линейных уравнений. На рабочем листе Excel я задал:

  • матрицу коэффициентов этой системы - myA;
  • вектор правых частей - myB;
  • вектор переменных - SolX5
  • в ячейках Myl1-Myl5 формулы, задающие соответствующие линейные уравнения. Фактически, я ввел одну формулу в ячейку myl1: {=СУММ(B30:F30*SolX5) -I30}




    Начало  Назад  Вперед



    Книжный магазин