Работа в Microsoft Excel XP



              

Поиск и исправление ошибок в вычислениях - часть 2


В этом упражнении вы используете возможности аудита формул в Exсel для обнаружения и исправления ошибок в формулах.

  1. На панели инструментов Стандартная нажмите кнопку Открыть (Open)
    . Появится диалоговое окно Открытие документа (Open).
  2. Дважды щелкните на файле FindErrors.xls. Документ FindErrors.xls откроется.
  3. Щелкните на ячейке D8. В строке формул появится выражение =СУММ(С2:С6).
  4. В меню Сервис (Tools) укажите на пункт Зависимости формул (Formula Auditing) и затем выберите Влияющие ячейки (Trace Precedents). Между ячейкой D8 и группой ячеек с С2 по С6 появится синяя стрелка, обозначающая, что ячейки в диапазоне С2:С6 являются прецедентами значения в ячейке D8.


  5. В меню Сервис (Tools) подведите указатель мыши к пункту Зависимости формул (Formula Auditing) и выберите Убрать все стрелки (Remove all Arrows). Стрелка исчезнет.
  6. Щелкните на ячейке D20. В строке формул появится выражение =СРЗНАЧ(D7,D15).
  7. В меню Сервис (Tools) укажите на пункт Зависимости формул (Formula Auditing) и выберите Источник ошибки (Trace Error). Появятся синие стрелки, указывающие из ячейки D20 на ячейки D7 и D15. Эти стрелки сообщают о том, что использование значений (или отсутствие значений, в данном случае) в указанных ячейках вызывает возникновение ошибки в ячейке D20.


  8. В меню Сервис (Tools) укажите на пункт Зависимости формул (Formula Auditing) и затем выберите Убрать все стрелки (Remove All Arrows). Стрелки исчезнут.
  9. Удалите текущую формулу из строки формул, введите =СРЗНАЧ(D8,D16) и нажмите (Enter). В ячейке D20 отобразится значение $149.08.
  10. На панели инструментов Стандартная нажмите кнопку Сохранить (Save)
    . Excel сохранит ваши изменения.
  11. Нажмите кнопку Закрыть (Close)
    . Документ FindErrors.xls закроется.




Содержание  Назад  Вперед