Финансовые расчеты в Excel


Рис. 5.17. Панель функции ЕСЛИ



Рис. 5.17. Панель функции ЕСЛИ



Рис. 5.17. Панель функции ЕСЛИ
Таким образом, функция ЕСЛИ возвращает значение, находящееся во втором аргументе, если условие в первом аргументе дает значение ИСТИНА, и значение, находящееся в третьем аргументе, если заданное условие при вычислении дает значение ЛОЖЬ.

В нашем случае в качестве логического выражения необходимо задать операцию сравнения на равенство табельных номеров из разных таблиц (ячейки D2 и G2). Если они одинаковы, то значением результата сравнения в первом аргументе является ИСТИНА, если нет - ЛОЖЬ.

Чтобы продемонстрировать работу функции ЕСЛИ на практике, выделите диапазон ячеек О2:О11, вызовите панель функции ЕСЛИ и задайте в качестве ее аргументов следующие выражения и числовые значения: D2=G2 (1-й аргумент), 1 (2-й аргумент) и 2 (3-й аргумент).

После нажатия комбинации клавиш [Ctrl+Enter] в ячейке О2 появится следующая формула:
=ЕСЛИ(D2=G2;1;2)

Как выглядит лист Оклады после ввода в диапазон О2:О11 указанной формулы, показано на рис. 5.18.

Обратите внимание на ячейки ОЗ и О10, в которых находится выделенное жирным шрифтом значение 2, а также на строки 3 и 10. Табельные номера в этих строках не совпадают. Поэтому первый аргумент функции ЕСЛИ при сравнении значений возвратил значение ЛОЖЬ, а ему соответствует значение, внесенное в третий аргумент, то есть число 2. Там же, где табельные номера совпадают, функция возвращает значение второго аргумента - число 1.








Начало  Назад  Вперед