Финансовые расчеты в Excel

купить уголь с доставкой в Новосибирске

Рис. 5.22. Рабочий лист с формулами для определения соответствия двух таблиц



Рис. 5.22. Рабочий лист с формулами для определения соответствия двух таблиц



Рис. 5.22. Рабочий лист с формулами для определения соответствия двух таблиц

Создание сложной формулы методом вложения

Формулы, как видите, получились довольно простыми и очень похожими. Однако работать с ними не совсем удобно. Поэтому попытаемся заменить эти шесть простых формул одной сложной. Выполняемый при этом процесс называется вложением одной формулы в другую. От состоит в замене ссылки на ячейку содержимым этой ячейки. Другими словами, если формула включает адрес ячейки, которая, в свою очередь, содержит формулу, наша задача - вместо адреса вставить формулу, находящуюся по этому адресу.

Для создания вложенной формулы выполните следующие действия.
1. Скопируйте из ячейки Р2 формулу без знака равенства.
2. Перейдите в ячейку Q2 и в строке формул выделите ссылку на ячейку Р2 и произведите вставку текста из буфера, нажав комбинацию клавиш [Ctrl+V].
3. Скопируйте из ячейки Q2 формулу без знака равенства.
4. Перейдите в ячейку R2 и в строке формул выделите ссылку на ячейку Q2 и произведите вставку текста из буфера, нажав комбинацию клавиш [Ctrl+V].

В результате этих манипуляций в ячейке R2 должна появиться такая формула:
=ЕСЛИ(Н2=ЛЕВСИМВ(С2;НАЙТИ(" ";С2)-1);ИСТИНА;ЛОЖЬ)

Аналогичным образом внесите формулы из ячеек N2, О2 и R2 в формулу, находящуюся в ячейке S2. Полученная формула будет выглядеть так:
=И(ЕПУСТО(L2);ЕСЛИ(D2=G2;ИСТИНА;ЛОЖЬ);
ЕСЛИ(Н2=ЛЕВСИМВ(С2;НАЙТИ(" ";С2)-1);ИСТИНА;ЛОЖЬ))









Начало  Назад  Вперед