Финансовые расчеты в Excel


Формирование названия единицы измерения



Формирование названия единицы измерения

Эта операция осуществляется в пятом блоке, который состоит из одной ячейки G14. Алгоритм основан на том же принципе, что и алгоритм предыдущего блока. Отличие заключается в том, что склоняется единица измерения - рубль.

Формула в ячейке G14 имеет следующий вид:
=ЕСЛИ(А4+B4+С4+D4+Е4+F4+G4=0;"Нуль рублей";
ЕСЛИ(ПРАВСИМВ(G5;1)="H";"рубль";
ЕСЛИ(ПРАВСИМВ(G5;1)="a";"рубля";
ЕСЛИ(ПРАВСИМВ(G5;1)="е";"рубля";
ЕСЛИ(ПРАВСИМВ(G5;1)="и";"рубля";"рублей")))))

Сначала в формуле проверяется, присутствует ли в данном числе целое значение рублей. Если нет, то выдается надпись Нуль рублей.







Начало  Назад  Вперед



Книжный магазин