Финансовые расчеты в Excel


Модуль, формирующий дату прописью



Модуль, формирующий дату прописью

Как и в случае определения названия дня недели, воспользуемся методом вложения формул и создадим модуль, формирующий дату прописью. Этот модуль будет располагаться в диапазоне А1:АЗ и состоять из трех ячеек (рис. 6.12). Модуль из двух ячеек в данном случае не получится, поскольку в Excel допускается только 7 уровней вложения функций.

В ячейке А2 модуля должна находиться следующая формула:
=ЕСЛИ(МЕСЯЦ(С1)=5;"мая";

ЕСЛИ(МЕСЯЦ(С1)= 6;"июня";

ЕСЛИ(МЕСЯЦ(С1)= 7;"июля";
ЕСЛИ(МЕСЯЦ(С1)=8;"августа";

ЕСЛИ(МЕСЯЦ(С1)= 9;"сентября";
ЕСЛИ(МЕСЯЦ(С1)=10;"октября";

ЕСЛИ(МЕСЯЦ(С1)=11;"ноября";"декабря")))))))

В ячейке A3 при помощи приведенной ниже формулы будет формироваться результат:
=СЦЕПИТЬ(" от ";ЕСЛИ(ДЕНЬ(С1)< = 9;0; "") ;

ДЕНЬ (C1);" ";
ЕСЛИ (МЕСЯЦ (С1)=1 ; "января" ;

ЕСЛИ (МЕСЯЦ (С1)=2 ; "февраля" ;
ЕСЛИ (МЕСЯЦ (C1)=3; "марта";

ЕСЛИ (МЕСЯЦ (С1)=4; "апреля" ;С2) ) ) ) ;

" ";ГОД(С1)x ;" года.")








Начало  Назад  Вперед



Книжный магазин